Can’t install wireshark on Debian Linux

Posted on

Problem :

I’m trying to install Wireshark on Debian (Debian 3.2.51-1) but i’m getting this error:

apt-get install wireshark
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wireshark : Depends: libwireshark2 (>= 1.8.0~rc1-1) but it is not going to be installed
             Depends: wireshark-common (= 1.8.2-5wheezy10) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Solution :

Try the following series of commands:

$ sudo apt-get clean
$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install wireshark

Leave a Reply

Your email address will not be published.