Error in installing Windows SDK (Newer version already installed)

Posted on

QUESTION :

I am trying to install the Windows SDK on my Windows 7 64bit machine.

But during the process of installation it gave me an error. I reviewed the log and it seems that it is due to a newer version of Microsoft Visual C++ 2010 runtime is already installed (10.0.40219 is installed compared with 10.0.30219, which is available in the package). Maybe it’s not compatible or it is having another issue.

I can uninstall this package and install the older one from the Windows SDK, but in the case that it wasn’t the issue, how can I return this package? Windows Update?

ANSWER :

I ran into the same problem. The solution is to uninstall “Microsoft Visual C++ Compilers 2010 Standard – enu – x86”, but there’s no entry in Control Panel/Programs and Features to do this. Additionally, you may need to uninstall:

Microsoft Visual C++  Compilers 2010 Standard - enu - x64

Note: that there are 2 spaces between the words C++ and Compilers.

The way I figured it out was by doing a registry search for the above 2 terms. When you find a regkey with a DisplayName that corresponds to each of the above strings, look for the value in LocalPackage – you’ll find the name of the MSI file to use to uninstall using the instructions below.

Launch an command prompt with administrative privileges. Navigate to C:WindowsInstaller. Execute the following command:

C:WindowsInstaller>msiexec /x <LocalPackage reg string value here>

Answer ‘Yes’ to the prompts and this will clean up completely. Repeat for the other string if needed. This will allow you to do a full install of Windows SDK 7.1

Note that in my case, I had Visual C++ 2010 Express edition installed followed by VS2010 SP1. Based on web search results, it seems this problem is caused by installation of the SP1. Also, I wanted to uninstall everything and only install Windows SDK 7.1 – so, I wiped stuff. Another alternate solution is to uncheck “Visual C++ Compilers” when installing Windows SDK 7.1 and that will keep the existing newer version and install the rest of the SDK properly.

This page has additional, relevant & important information: http://msdn.microsoft.com/en-us/visualc/gg697159

Microsoft seems to have released a fix for this actually, KB2519277.

You don’t need to uninstall VS2010 SP1’s compilers anymore, or deal with finding the correct msi package to uninstall.

If you are trying to install the SDK to a system with VS2010 SP1 update already installed, simply deselect the compilers in the SDK installer and install everything else you want. After the SDK is installed, run the “Microsoft Visual C++ 2010 Service Pack 1 Compiler Update for the Windows SDK 7.1” to install the SDK’s compilers.

If you are trying to repair an SDK install which the VS2010 SP1 update removed the compilers from, simply run the “Microsoft Visual C++ 2010 Service Pack 1 Compiler Update for the Windows SDK 7.1”, and it will reinstall the compilers.

Leave a Reply

Your email address will not be published. Required fields are marked *