Internet Connection Sharing not working on Windows10

Posted on

QUESTION :

I cannot share the internet connection between two PCs using ICS. Here is my setup:

  • PC 1 is the ICS host. It has internet acces through Wifi.
  • Both PC are connected to a switch by Ethernet cables.
  • The switch does not have internet access.

On PC1 I enabled sharing through Network connection properties.

enter image description here

This is what i get on PC1:

enter image description here

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . : 192.168.137.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : home
   IPv4 Address. . . . . . . . . . . : 192.168.2.24
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.2.1

And this on PC2:

enter image description here
Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . : 192.168.0.2
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1

PC2 reports no internet connection. Both network adapter are labeled as unknown network instead of “VIRGIN002”.

Shouldn’t the PC2 have an IP address in the range 192.168.137.X for it to work?

Thanks.

ANSWER :

I got it working by setting a static IP address for PC2 (192.168.137.3)

Leave a Reply

Your email address will not be published. Required fields are marked *