Ubuntu 14.04LTS on ASUS wifi disconnecting and reconnecting

Posted on

QUESTION :

Hi im a beginner and started out with replacing my operating system with ubuntu 14.04. It was working fine until recently nothing that I know of has been changed. When I use rfkill list i get: 0: phy0: Wireless LAN soft blocked: no hard blocked: yes 1: asus-wlan: wireless lan soft blocked: no hard blocked: no 2: asus-bluetooth: bluetooth sb:no sb:no

when i close my laptop lid and reopen it, the wifi connects to the network and shows that it is not hard blocked anymore. Any help or suggestions would be appreciated.

iwconfig gives me eth0: no wireless extensions; lo:no wireless extension; wlan0: IEEE 802.11bgn ESSID:”XXXXXXX” power management is off.

when i run lspci -vnn | grep Network i receive: 02:00.0 Network controller [0280]: Ralink corp. RT5390 wireless 802.11n 1T/1R PCIe [1814:5390]

and time is kinda important,not that anyones elses time isnt important, and i know i was stupid for this but i installed this on my laptop i use for school and work and need it for monday.

edit:when i run lsmod | grep asus i get:

asus_nb_wmi 16990 0
asus_wmi 24191 1 asus_nb_wmi

ANSWER :

http://ubuntuforums.org/showthread.php?t=2181558

echo “options asus_nb_wmi wapf=4” | sudo tee /etc/modprobe.d/asus_nb_wmi.conf

but your answer helped me either way thanks again bro would give rep if i could lol.

thanks and rep go to Jeremy31 for help.

Leave a Reply

Your email address will not be published. Required fields are marked *