Unable to access network resources through VPN

Posted on

QUESTION :

I’m currently attempting to connect one of our computers in the office to a client VPN. My development machine is running Windows 7, and can connect and see resources just fine. The problem computer is running Windows XP. They’re both within the same network.

Using the same credentials at both computers, the VPN connection (using the built in Windows network connections) works just fine. So far, so good. An IP address is assigned, and comparing both machines shows they’re still in the same subnet.

The problem is that the XP machine cannot see ANY of the computers in the client network. I tried a tracert to a target machine on the Windows 7 box, and the first item that comes up is the .0 address. Pinging it gives responses. Trying it on the Windows XP machine, however, comes up with just timeouts.

Trying to trace to www.google.com allows the address to resolve (probably part of the cached resolutions), but results in just timeouts.

I double-checked to make sure that the Windows firewall was not on, and trying to open the settings brings up a notification that the firewall service wasn’t running, which leads me to believe that it’s definitely not on.

From my best guess, I’ve managed to connect the XP machine to a black hole of some sort. There’s obviously something strange going on, but I’m not sure where I should be looking.

ANSWER :

Turns out the issue is with the client network; I’ve managed to reproduce the issue several times on multiple machines in the office. I can’t maintain a stable VPN connection for even an hour; it will drop the connection entirely, or it will start displaying these symptoms again.

I can work around the problem by disconnecting from the VPN, and reconnect. This does not always solve the issue, but when it does not, I request a switch reboot from the client, and then it works.

Leave a Reply

Your email address will not be published.